Microsoft 365 Services
Incident Report for
ITS Network & Systems
Resolved
Microsoft has marked these issues as resolved! If you notice any additional issues or impact, please contact the ITS Service desk at
https://support.ucsd.edu
,
support@ucsd.edu
or at (858) 246-4357.
Posted
Jul
29
,
2026
-
16:40
PDT
Investigating
Microsoft is reporting an issue that may be affecting access to various Microsoft 365 services. Updates to this status can be seen here:
https://x.com/MSFT365Status/status/2080313098351575176
If you notice any additional issues or impact, please contact the ITS Service desk at
https://support.ucsd.edu
,
support@ucsd.edu
or at (858) 246-4357.
Posted
Jul
23
,
2026
-
11:49
PDT
This incident affected: Business Services, Communication and Collaboration, and Email.
×
Subscribe to Incident
Subscribe to updates for
Microsoft 365 Services
via . You'll receive .