Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2025 - 12:00 PDT
Scheduled
ITS has scheduled the following maintenance:
When: Friday, September 5 at 3:00 p.m. - Wednesday, September 10 at 12:00 p.m.
Message: The reservation systems for the following departments will be down from Friday, September 5 starting at 3:00 p.m. PT and reopen on Wednesday, September 10 at approximately 12:00 p.m. PT: - Campus Performances and Events - Cross Cultural Center - Eleanor Roosevelt College - Music Department - Qualcomm Institute - Recreation - University Centers
Please contact ITS Service Desk at (858)246-HELP(4357) or servicedesk@ucsd.edu if you have any questions or concerns.
Posted Aug 27, 2025 - 10:09 PDT
This scheduled maintenance affected: Academic Services.