Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jul 15, 2026 - 14:16 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 15, 2026 - 13:30 PDT
Scheduled
STAFF & FACULTY: The initial TSS Schedule of Classes provides the core functionality needed to search for and review Fall 2026 course offerings. As part of the initial release, some information may display differently from the previous Schedule of Classes, and some features and formatting continue to be refined. The Registrar scheduling team is also continuing to process Fall 2026 change requests and validate course approvals in TSS. Read the full details in our update on the TSS Schedule of Classes functionality to learn more about known issues and what is being worked on. https://esr.ucsd.edu/news/posts/sis-tss-schedule-of-classes-functionality-jul-26.html