Triton Enrollment Authorization (TEA) system down
Incident Report for
ITS Network & Systems
Resolved
This incident has been resolved.
Posted
Jul
29
,
2026
-
12:22
PDT
Investigating
The Triton Enrollment Authorization (TEA) system is currently unavailable while fixes are being implemented. We deeply apologize for any inconvenience this may cause, and will update this page with additional details as they become available.
Posted
Jul
29
,
2026
-
12:17
PDT
This incident affected: Academic Services.
×
Subscribe to Incident
Subscribe to updates for
Triton Enrollment Authorization (TEA) system down
via . You'll receive .