Find a Student

Incident Report for ITS Network & Systems

Resolved

ITS has confirmed that the issues affecting Find A Student have been resolved. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Sep 22, 2026 - 14:16 PDT

Update

Find a Student is now restored and available to staff and faculty. Student access is not yet available and will be communicated in the coming weeks.

Please review the initial release article for details on known data gaps and TSS navigation tips:

https://esr.ucsd.edu/news/posts/sis-tss-findastudent.html
Posted Sep 17, 2026 - 10:21 PDT

Update

Find a Student is not yet available in TSS. For a full list of current limitations and known issues with TSS, please refer to the following: TSS Current Limitations & Known Issues.

If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 28, 2026 - 13:50 PDT

Update

Find a Student is not yet available in TSS. For a full list of current limitations and known issues with TSS, please refer to the following: TSS Current Limitations & Known Issues.

If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 21, 2026 - 13:01 PDT

Update

We're still investigating how to resolve the issues impacting Find A Student - thank you for your patience! If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 06, 2026 - 10:55 PDT

Update

We're still investigating how to resolve the issues impacting Find A Student - thank you for your patience! If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 29, 2026 - 16:24 PDT

Investigating

ITS is continuing to investigate the cause of issues with Find a Student. Thank you for your continued patience as our team works to restore these services as quickly as possible. Updates and additional details will be shared here as they become available. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 27, 2026 - 09:56 PDT

Monitoring

ITS has implemented a fix for the issues with Find a Student. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 27, 2026 - 09:43 PDT
This incident affected: Academic Services.