Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2026 - 12:00 PDT
Scheduled
Emergency maintenance will be conducted to to resolve a certificate error that is appearing for some of the applications on the server. Applications that will be impacted will include the Virtual Advising Center (VAC), Staff portal (ugcportal), and Degree and Diploma Application (DDA).
Posted Sep 02, 2026 - 09:35 PDT
This scheduled maintenance affected: Academic Services.