In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary. Aug 01, 2026 - 07:00 PDT Scheduled - What: Financial Aid Systems Maintenance When: Saturday, August 1 at 7:00 a.m. PT to Sunday, August 2 at 8:00 a.m. PT Message: Due to system maintenance FinancialAid will not be available from Saturday, August 1 at 7:00 a.m. PT to Sunday, August 2 at 8:00 a.m. PT. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357. Aug 1, 2026 07:00 - Aug 2, 2026 18:00 PDT
Posted Aug 01, 2026 - 10:48 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2026 - 07:00 PDT
Scheduled
What: Financial Aid Systems Maintainance When: Saturday, August 1 at 7:00 a.m. PT to Sunday, August 2 at 8:00 a.m. PT
Message: Due to system maintenance FinancialAid will not be available from Saturday, August 1 at 7:00 a.m. PT to Sunday, August 2 at 8:00 a.m. PT. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 31, 2026 - 07:26 PDT
This scheduled maintenance affected: Academic Services.