Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2025 - 17:00 PDT
Scheduled
The Recruit application will be undergoing maintenance on Tuesday, September 2, 5:00pm to 6:00pm
We will be updating the production database system.
We anticipate a period of 30 minutes during which the system may be unavailable. We’re scheduling the update at a time of low activity to minimize interruptions,
We will follow up with a notification when the work is concluded.
Posted Aug 26, 2025 - 16:50 PDT
This scheduled maintenance affected: Business Services.