We are continuing to monitor for any further issues.
Posted Aug 26, 2026 - 20:28 PDT
Update
TEA (student) is back online. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 26, 2026 - 20:27 PDT
Monitoring
TSS has returned to normal performance. TEA will continue to be offline for now.
ITS is continuing to investigate the cause of issues with TSS slowness. In addition, we have now received reports that TEA (Triton Enrollment Authorization) is currently offline. Thank you for your continued patience as our team works to restore these services as quickly as possible. Updates and additional details will be shared here as they become available. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 26, 2026 - 16:02 PDT
Investigating
ITS is aware of a 503 error message with TSS as well as extreme slowness of use.These services may be slow or unavailable at this time. Thank you for your patience as our team works to restore functionality for these services. Updates and additional details will be shared here as they become available.