TSS maintenance has been completed. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Aug 06, 2026 - 11:00 PDT
Monitoring
TSS maintenance has been completed. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 30, 2026 - 11:22 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 30, 2026 - 08:58 PDT
Update
TSS maintenance is taking longer than expected. If you have a booking window that starts today, you will receive communications from the university notifying you as soon as the platform is available.
We sincerely apologize for the inconvenience. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 30, 2026 - 08:52 PDT
Update
Maintenance is taking a little longer than expected. We are now expecting the work to be done by 9:30 am. Thank you for your patience!
Posted Jul 30, 2026 - 08:24 PDT
Identified
TSS will be offline for emergency maintenance. Service is expected to be restored by around 8:20AM.